












	
	
		
	
		
	
	
	
	


<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
	
	











<head>
	<link rel="alternate" hreflang="en" href="https://www.idginsiderpro.com/article/3511598/can-developers-dictate-how-their-software-is-used.html" />
	
	
	
	<!-- metas -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />		
	<title>Can developers dictate how their software is used? | InsiderPro</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<script>
	// Include CSS file for insider modal - used in insider_reg_api.js
	function addCSS(filename){
		 var headerTag = document.querySelector("header#banner");
		 var styleTag = document.createElement('link');
		 styleTag.href = filename;
		 styleTag.className = "oc-modal";
		 styleTag.type = 'text/css';
		 styleTag.rel = 'stylesheet';
		 headerTag.parentNode.insertBefore(styleTag, headerTag);
	}
	</script>
		
	<!-- ad-related js -->
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	
	<script type="text/javascript" src="/www/js/apollo-locales.js?v=20200121111141"></script>
	
	
	











<script src="//d2zv5rkii46miq.cloudfront.net/0/latest/cmp_shim.js"></script>

<script>
var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

consent.infostorage = consent.infostorage || {};
consent.infostorage.queue = consent.infostorage.queue || [];

consent.adsel = consent.adsel || {};
consent.adsel.queue = consent.adsel.queue || [];

consent.contentsel = consent.contentsel || {};
consent.contentsel.queue = consent.contentsel.queue || [];

consent.socmedia = consent.socmedia || {};
consent.socmedia.queue = consent.socmedia.queue || [];

consent.blueconic = consent.blueconic || {};
consent.blueconic.queue = consent.blueconic.queue || [];

consent.digitalelement = consent.digitalelement || {};
consent.digitalelement.queue = consent.digitalelement.queue || [];

consent.purposes = consent.purposes || {};
consent.purposes.standard = consent.purposes.standard || [];
consent.purposes.custom = consent.purposes.custom || [];
consent.vendors = consent.vendors || {};
consent.vendors.standard = consent.vendors.standard || [];
consent.vendors.custom = consent.vendors.custom || [];

var dataLayer = window.dataLayer = window.dataLayer || [];
</script>








<script>

$(window).trigger("runConsent", [consent.ads.queue]);
$(window).trigger("runConsent", [consent.infostorage.queue]);
$(window).trigger("runConsent", [consent.adsel.queue]);
$(window).trigger("runConsent", [consent.contentsel.queue]);
$(window).trigger("runConsent", [consent.socmedia.queue]);
$(window).trigger("runConsent", [consent.blueconic.queue]);
$(window).trigger("runConsent", [consent.digitalelement.queue]);
</script>

	
	
	
	
		










<script>
// this javascript is for retrieving locale-specific ad units for DFP - see mapping in apollo-locales.js
// getting locale and editions for the site the reader is viewing
let brandAbbrev = "insp";
let brandConfigBrandId = "134217728";
//let myLocale = getLocale(); // getting locale on page load from URL, IP, geolocation - this will always be something. If 0, it's the global/default/core view.
let countryCode = "";
let getSlugFromId = getApolloLocaleIdMap();
let getIdFromSlug = getApolloLocaleSlugMap();

// if selectedLocale cookie exists, get locale
if (typeof getSelectedLocale() !== 'undefined'  && getSelectedLocale() === getLocale()) { // get locale from cookie if available otherwise, use another locale source (from geolocation, url slug, etc.)
 	countryCode = getSlugFromId[getSelectedLocale()];
} else {
	countryCode = getSlugFromId[getLocale()];
}
//console.log("+++ 1) in locales.editions.jsp - COUNTRY CODE IS DEFINED AS: "+countryCode+"+++");
// if countryCode is empty string at this point, it means localeId = 0 which is global (default/core)...
if (countryCode == "") {
	countryCode = "us"; // country code for default global is currently US
}
//console.log("====INSIDE locales-editions.jsp - getSelectedLocale() = " + getSelectedLocale() + " and getLocale() = " + getLocale() + " and countryCode = " + countryCode);
//US social media accounts are the default if locale cannot be determined
var twitterUrl = "https://twitter.com/InsiderPro_IDG";
var linkedInUrl = "https://www.linkedin.com/company/insider-pro-idg";
var facebookUrl = "";
var youTubeUrl = "";
var twitterHandle = "InsiderPro_IDG";

if (countryCode === 'asean') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'middle-east') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'uk') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'in') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}
if (countryCode === 'africa') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}
if (countryCode === 'au') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'nz') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}

//US business unit is the default if locale cannot be determined
var busUnit = "";
//cookie policy page
var localeEdition = "";
var busUnitAddress = "";
if (countryCode === 'asean') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'middle-east') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'uk') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'in') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'africa') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'au') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'nz') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
</script>

	
	
	<script src="/www/js/init_device.js"></script>
	
	

	

	
		
		
			
			<script src="/www.idge/js/thm_pre.js?v=20200121111141"></script>
		
	
	
	
		
				
		
		
		
	

	<link rel="canonical" href="https://www.idginsiderpro.com/article/3511598/can-developers-dictate-how-their-software-is-used.html" />
	
	
		
	

	<meta itemprop="url" content="https://www.idginsiderpro.com/article/3511598/can-developers-dictate-how-their-software-is-used.html" />
	<meta name="description" content="The politics of the Silicon Valley are colliding with customers and impacting innocent bystanders who put their trust in open source software." />
	
		
			<meta name="DC.date.issued" content="2020-01-22T05:55-05:00" />
			<meta name="date" content="2020-01-22" />
			
		
		
		
		
	
	
	
	
		
		
		
			
			
				
			
			
			
		
	
	
		
		
			<meta property="og:title" content="Can developers dictate how their software is used?">
		
	
	<meta property="og:description" content="The politics of the Silicon Valley are colliding with customers and impacting innocent bystanders who put their trust in open source software.">	
	
	
		
			<meta property="og:image" content="https://images.techhive.com/images/article/2016/11/six-big-projects-that-went-open-source-1-100692064-large.3x2.jpg" />
			<meta property="og:image:width" content="700" />
			<meta property="og:image:height" content="467" />
			<meta itemprop="image" content="https://images.techhive.com/images/article/2016/11/six-big-projects-that-went-open-source-1-100692064-large.3x2.jpg">
			<meta itemprop="thumbnailURl" content="https://images.techhive.com/images/article/2016/11/six-big-projects-that-went-open-source-1-100692064-large.3x2.jpg" />
			<link rel="image_src" href="https://images.techhive.com/images/article/2016/11/six-big-projects-that-went-open-source-1-100692064-large.3x2.jpg" />
			<meta name="twitter:image" content="https://images.techhive.com/images/article/2016/11/six-big-projects-that-went-open-source-1-100692064-large.3x2.jpg" />
		
		
	
	
		
			<meta property="og:type" content="article" />
			
			
			
			
			
			
			
			
			
			<meta name="author" content="Andy Patrizio">
			
			
			
			
			
		
		 
		
	<meta property="og:site_name" content="InsiderPro" />
	
	
		
			<meta property="og:url" content="https://www.idginsiderpro.com/article/3511598/can-developers-dictate-how-their-software-is-used.html">
		
		
	
	
	<!-- Use Twitter Summary Card with Large Image for articles and videos -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	

	<meta name="twitter:site" content="@InsiderPro_IDG">
	<meta name="twitter:description" content="The politics of the Silicon Valley are colliding with customers and impacting innocent bystanders who put their trust in open source software.">

	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	<meta name="rating" content="General">
	
	<meta name="robots" content="NOODP,NOYDIR" />
	
	
	
	
		<meta name="msvalidate.01" content="B6D65511A0CC5522E695818081C251B8" />
	
		
	<!-- pagination -->
	
	
	
	
	
	
	
	
	
	
	
					
		
		
			
			
		
	
	
	<!-- css -->
	
	
	
	
	
		
			
			
			
			
				
					
						
						
							<link rel="stylesheet" href="/www/css/article.css?v=20200121111141" />
						
					
					
					
					
			
				
		
		
		
		<link rel="stylesheet" href="/www.idge/css/print.css" media="print" />
		
	
	
		
			
			
				
				
					<link rel="stylesheet" href="/www.idge.insp/css/article.css?v=20200121111141" />
				
			
		
	
	
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css" />
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css" />
	<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]--> 
	
	

	
		
	
	
	
		<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.6.1/css/all.css" integrity="sha384-gfdkjb5BdAXd+lj+gudLWI+BXq4IuLW5IT+brZEZsLFm++aCMlF1V92rMkPaX4PP" crossorigin="anonymous">
	
	
	
		<link rel="stylesheet" href="https://use.typekit.net/ylv4wjj.css" />
	
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" type="image/x-icon" href="https://alt.idgesg.net/images/furniture/insiderpro/favicon_package/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://alt.idgesg.net/images/furniture/insiderpro/favicon_package/IP-favicon-144x144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://alt.idgesg.net/images/furniture/insiderpro/favicon_package/IP-favicon-114x114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://alt.idgesg.net/images/furniture/insiderpro/favicon_package/IP-favicon-72x72.png" />
	<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://alt.idgesg.net/images/furniture/insiderpro/favicon_package/IP-favicon-57x57.png" />
	<link rel="apple-touch-icon" href="https://alt.idgesg.net/images/furniture/insiderpro/favicon_package/apple-touch-icon.png" />
	
	
	
	
	
	
	



	
	
	
















	

	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	<script>
		const articlePaidAccess = [];
	</script>
	
	
	
		
			
				
			
			
			
			
			
			
			
			

				
					
						<script>
							articlePaidAccess.push("IPFull");
						</script>
					
				
			
		
		
		
	
	
	
	
	
	
	





	
		
	
		
	
	





		
		  
		
		
		
		

	
	
	
	
	

	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
		
	
	

	<script>
	var supMontMods = false;
	</script>
	
	
	
	
		
			<script>
				supMontMods = true;
			</script>
			
		
		
		
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	

	
	
	
	
	
		<script>
		window.ntvConfig = window.ntvConfig || {} ;
		window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
		var segs = localStorage.getItem('_pnativo');
		if (segs) {
		  window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
		}
		</script>
	
	
	
	

	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
	
	
	
	<script>
	var insiderSignedIn = document.cookie.indexOf("nsdr") > -1; //check if Insider cookie exists
	var idg_uuid = $.cookie('idg_uuid') || '';
	
	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	if (insiderSignedIn) {
		var insiderToken = IDG.insiderReg.readCookie("nsdr");
		var tokens = IDG.insiderReg.readCookieProperty(insiderToken);
		if (!(tokens['jobPosition']===undefined)) {
			//dlJobPosition = tokens['jobPosition'];
			//OC-1647 change to indicate this data was remove
			dlJobPosition = "removed";
		}
		if (!(tokens['jobFunction']===undefined)) {
			dlJobFunction = tokens['jobFunction'];
		}
		if (!(tokens['industry']===undefined)) {
			dlIndustry = tokens['industry'];
		}
	}
	
	insiderSignedIn = insiderSignedIn.toString(); //per Infotrust this needs to be a string, not a boolean
	
	var sincePublished = '0 days';
	sincePublished = sincePublished.split(" ")[0];
	
	//get edition from countryCode
	var edition = '';
	if (typeof countryCode !== 'undefined' && countryCode !== "") {//should be defined in locales-editions.jsp if brand has editions
		edition = countryCode.toLowerCase();
	}
	
	dataLayer.push({
		'articleId': '3511598',
		'articleDisplayId':'1',
		'articleHasVideo':'false',
		'articleLocale': 'global',
		'articleTitle': 'Can developers dictate how their software is used?',
		'articleType': 'Feature',
		'audience':'enterprise',
		'author':'Andy Patrizio',
		'blogName':'',
		'brandpost': 'false',
		'categoryIdAll': '3646, 3248, 3808, 3871',
		'categoryIdList':'3646,3248,3808,3871',
		'categoryIdPrimary': '3646',
		'contentStrategy': '',
		'contentType':'feature',
		'datePublished':'2020-01-22',
		'dateUpdated':'2020-01-22',
		'daysSincePublished':"0",
		'daysSinceUpdated':'0',
		'de_normalized_company_name':$.cookie('de_normalized_company_name'),
		'displayType':'article',
		'edition':edition,
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-300704-32',
		'geolocEnabled':'false',
		'goldenTaxonomyIdAll': '241, 993, 244, 683',
		'goldenTaxonomyIdPrimary': '241',
		'goldenTaxonomyIdList': '993,244,683',
		'industry': dlIndustry,
		'insiderSignedIn':insiderSignedIn,
		'ip_normalized_company_name':$.cookie('ip_normalized_company_name'),
		'isBlog':'false',
		'isInsiderContent':'false',
		'isICN': 'false',
		'jobFunction': dlJobFunction,
		'jobPosition': dlJobPosition,
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'software development',
		'ancestorGoldenCategories': 'insider pro',
		'primaryCategoryAll': 'software development, open source, devops, technology industry',
		'primaryCategoryList': 'open source,devops,technology industry',
		'primaryAncestorCategoryList': 'software development,insider pro',
		'prodCategories':prodCategories.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodNames':prodNames.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1),
		'property': 'insiderpro',
		'propertyCountry':'US',
		'purchaseIntent':'notapplicable',
		'skimlinksId':'',
		'source':'insiderpro',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'youtubeId':''
	});
	</script>

	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>





	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WR6LD2P"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WR6LD2P');</script>
	<!-- End Google Tag Manager -->

	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	

	

	
		










<script>
// IDGMPM-16419 - updated in IDGMPM-16933
	!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
	  permutive.addon('web', {
	    page: {
	      type: stringFromDataLayer('displayType'),
	      language: 'en',
	      tags: stringFromDataLayer('tags').split(","),
	      audience: stringFromDataLayer('audience'),
	      description: 'The politics of the Silicon Valley are colliding with customers and impacting innocent bystanders who put their trust in open source software.',
	      
	      article: {
	        authors: stringFromDataLayer('author').split(","),
	        description: 'The politics of the Silicon Valley are colliding with customers and impacting innocent bystanders who put their trust in open source software.',
	        id: stringFromDataLayer('articleId'),
	        isInsiderContent: (stringFromDataLayer('isInsiderContent') == "true"),
	        modifiedAt: "2020-01-22T05:54:49Z",
	        publishedAt: "2020-01-22T05:54:49Z",
	        source: stringFromDataLayer('source'),
	        title: stringFromDataLayer('articleTitle'),
	        type: stringFromDataLayer('articleType'),
	        purchaseIntent: stringFromDataLayer('purchaseIntent')
	      },
	      
	      ads: {
	        adblocker: (adBlockStatus == "true"), //detected further up the page
	        enabled: true
	      },
	      gTax: {
	        primaryIds: [241,],
	        secondaryIds: [993,244,683,241]
	      },
	      tax: {
	    	  primaryCategories: stringFromDataLayer('ancestorGoldenCategories').length > 0 ? stringFromDataLayer('ancestorGoldenCategories').split(",").concat(stringFromDataLayer('primaryCategory')) : [stringFromDataLayer('primaryCategory')] ,
	          secondaryCategories: stringFromDataLayer('primaryAncestorCategoryList').length > 0 ? stringFromDataLayer('primaryCategoryList').split(",").concat(stringFromDataLayer('primaryAncestorCategoryList').split(",")) : stringFromDataLayer('primaryCategoryList').split(",")
	      }
	    }
	  });

	  dlJobPosition = dlJobPosition || null;
	  dlIndustry = dlIndustry || null;

	  if (dlJobPosition !== '' || dlIndustry !== '' || stringFromDataLayer('userId') !== '') {
		  if (stringFromDataLayer('userId') !== '') {
				var userData = {};

				var hermesAttrs = {
					"companySize" : "543ea0bd-604a-4011-99e7-806fc8979b5e",
					"country" : "ea76d652-29bd-4a6c-ae50-a5d08ea28c5e",
				};
				var userKeys = Object.keys(hermesAttrs);

				$.ajax({
					type: "get",
				    crossDomain: true,
					url: "https://lqxgcyk808.execute-api.us-east-1.amazonaws.com/prod_h2/api/v1/profiles/" + idg_uuid,
					dataType: "json",
					data: {}, 
					headers : {
						"Content-Type": "application/x-www-form-urlencoded",
						"x-api-key":"HLyMXLISSW7HAYGgbx2Vb1Gf1OLcGmMG5BcwZ4Vb"
					}
				}).done(function(responseData){ 
					userKeys.forEach(function(key) {
						if (typeof(responseData.attrs[hermesAttrs[key]].option_label) !== "undefined") { 
							userData[key] = responseData.attrs[hermesAttrs[key]].option_label;
						}
						else { 
							userData[key] = responseData.attrs[hermesAttrs[key]].value;
						}
					});

					window.permutive.track('User', {
					  companySize: userData['companySize'],
					  country: userData['country'],
					  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
					  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
					  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
					  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
					})
					
					
				}).fail(function(data){
					//console.log("Error retrieving data: " + data.responseJSON.error);
				});  

			}
			else {
				window.permutive.track('User', {
				  companySize: null,
				  country: null,
				  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
				  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
				  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
				  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
				});
			}
	  }
	
	  //product js vars defined in document-head	  
	  if (prodNames !== '' || prodManufacturers !== '' || prodCategories !== '' || prodVendors !== '') {
		  window.permutive.track('Product', {
			  names: stringFromDataLayer('prodNames').split("|"),
			  categories: stringFromDataLayer('prodCategories').split("|"),
			  manufacturers: stringFromDataLayer('prodManufacturers').split("|"),
			  vendors: stringFromDataLayer('prodVendors').split("|")
		});

	  }
		 

</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
	
		<script>
			tp = window["tp"] || [];
			const cats = "open source,devops,technology industry";
			const tags = "";
			var pianoTags = articlePaidAccess;
			
			
					window.addEventListener("message", receiveMessage, false);
					
					function receiveMessage(event) {
						if (event.origin.match(/tinypass/gi)) {
							const eventObj = JSON.parse(event.data);
							if (eventObj.event === "loaded") {
								gateArticle();
							}
						}
					}
					function gateArticle() {
						const teaser = document.querySelector(".teaser");
						const fullArticle = document.querySelector(".premium");
						const emptyDiv = document.querySelector(".empty-div")
						teaser.style.display = "block";
						fullArticle.style.display = "none";
						emptyDiv.style.display = "block";
					}
			
			if (cats !== "") {
				pianoTags = pianoTags.concat(cats.split(","));
			}
			if (tags !== "") {
				pianoTags = pianoTags.concat(tags.split(","));
			}
			const pianoDatePublished = document.querySelector("meta[name='DC.date.issued']") !== null ? document.querySelector("meta[name='DC.date.issued']").content : "";
			tp.push(["setContentCreated", pianoDatePublished]);
			tp.push(["setContentAuthor", "Andy Patrizio"]);
			tp.push(["setContentSection", "software development"]);
			tp.push(["setTags", pianoTags]);
            tp.push(["setCustomVariable", "contentType", "feature"]);
            tp.push(["setCustomVariable", "contentId", "3511598"]);
            tp.push(["setCustomVariable", "contentTitle", "Can developers dictate how their software is used?"]);
            tp.push(["setCustomVariable", "isPaid", "true"]);
            tp.push(["setCustomVariable", "paidAccesses", articlePaidAccess]);
		    
		    tp.push(["setUsePianoIdUserProvider", true ]);
		    tp.push(["setContentIsNative", false]);
		    tp.push(["init", function() {
		    		document.addEventListener('click', function (event) {
		    			if (!event.target.matches('.ip-login') && !event.target.matches('.ip-logout')) return;
		    			event.preventDefault();
		    			
		    			if (event.target.matches('.ip-login')) {
		    				tp.pianoId.show({
		    					loggedIn: function() {
		    							window.setTimeout(function() {
		    							location.reload();
		    						},4000);
		    					}});
		    			}
		    			if (event.target.matches('.ip-logout')) {
		    				tp.pianoId.logout(function() {
		    					location.reload();
		    				});
		    			}
		    			//console.log(event.target);
		    			
		    		}, false);
		        if (tp.user.isUserValid()) {
		        		document.querySelectorAll(".ip-logged-in").forEach(function(e) {
		        			e.style.display = 'block';
		        		});
		        		document.querySelectorAll(".ip-logged-out").forEach(function(e) {
		        			e.style.display = 'none';
		        		});
		        		document.querySelector(".mega-grp.marketing-text").style.display = "none";
		        }
		    }]);
		    tp.push(["addHandler", "checkoutCustomEvent", function(event){
				if (event.eventName === "loginRefresh") {
					//console.log("loginRefresh custom event fired");
    					tp.pianoId.show({
						loggedIn: function() {
								window.setTimeout(function() {
								location.reload();
						},1000);
					}});
				}
		        
		    }]);
		    tp.push(["addHandler", "checkoutStateChange", function(stateView){
		        if (stateView.stateName === "alreadyHasAccess") {
			        	window.setTimeout(function() {
							location.reload();
					},4000);
		        }
		    } ]);
		    
		    
		    var _iub = _iub || [];
			_iub.csConfiguration = {"lang":"en","siteId":1622994,
									"priorConsent":false,									
									"consentOnButton":false,
									"consentOnElement":"   ",									
									"cookiePolicyId":63224281,
									"cookiePolicyUrl":"https://resources.idg.com/information-on-cookies", 
									"banner":{ "position":"bottom",
												"content" :"Notice<br><br>Hello IDG Insider Pro reader - while we don't have ads on this site, " +
															"we are using cookies to enable our payment platform and understand site traffic.<br>" + 
															"IDG Communications has a <a href='http://idginsiderpro.com/about/cookie-policy.html'>cookie policy</a>," +
															" if you are interested in reading more.<br>" 
											}
								  }			
		</script>
		<script type="text/javascript" src="//cdn.iubenda.com/cs/iubenda_cs.js" charset="UTF-8" async></script>
	

	
</head>



	<body id="article3511598" class="article insiderpro">
		
			
			
				
			
		
		











	
		<link rel="stylesheet" href="/www/css/oc-header.css?v=20200121111141" />
		<link rel="stylesheet" href="/www.idge.insp/css/oc-header.css?v=20200121111141" />
		











<header id="banner">
	
	
	
</header>
<script>
$(document).ready(function() {
	var params = {
			def : "blox4.dynamic",
			geo : getLocale(),
			definition : "nav.fixed",
			placement : "Nav Fixed"
			}
		$.get(
			"/napi/tile",
			params,
			function(data, status, xhr) {
				$('#custom_header').html(data);
			},
			"html");
});
	
//This is for sites without editions but using the new header and mega menu.
var hasEditions = "";
if ("" !== "" && "" !== null) {
	hasEditions = ;
}
</script>
<section id="oc-head" class="">
		<div class="oc-head-inner">
			<div class="oc-head-left">
				<a href="/" class="masthead"><span class="logo">insiderpro</span></a>
				
				
				
			</div>
			
			<div id="custom_header">
			</div>
			
			<div class="oc-head-right">
				
				
					<span class="insiderpro-controls">
						<div class="ip-logged-out">
							<a href="#" class="ip-login">LOGIN</a> 
							<span class="bar">|</span>
							<a href="/subscribe" class="ip-subscribe">SUBSCRIBE</a>
						</div>
						<div class="ip-logged-in">
							<a href="#" class="ip-logout">LOGOUT</a> 
							<span class="bar">|</span>
							<a href="/subscribe/my-account" class="ip-my-account">MY ACCOUNT</a>
						</div>
					</span>
					
				
				
				
					<a href="#search" class="search-btn"><i class="fas fa-search"></i></a>
					<div class="search-expand">
						<a href="" class="mega-close ss-delete"></a>
						
					    
					   		  
						    	<div class="gcse-searchbox" >
								     <script>
										(function() {
											var cx = '011881588825642368632:mmdiyi0wlog';
											var gcse = document.createElement('script');
											gcse.type = 'text/javascript';
											gcse.async = true;
											gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
											var s = document.getElementsByTagName('script')[0];
											s.parentNode.insertBefore(gcse, s);
										})();
									</script>
									<gcse:searchbox-only resultsUrl="/search"></gcse:searchbox-only>
									<script>
										$(window).load(function(){
											$('#gsc-i-id1').attr('placeholder','Start Searching');
										})
									</script>	
								</div>
							
							
						
						
					</div>
				
				
					<a class="mega-btn"></a>
					
				
			</div>
		</div>
</section>











<script>
$(document).ready(function() {	
	var paramsmegamenu1 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 1"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu1,
			function(data, status, xhr) {
				$('#megacolumn1').html(data);
				if (hasEditions === true) {
					addSlugCode();
				}
			},
			"html");
	var paramsmegamenu2 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 2"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu2,
			function(data, status, xhr) {
				$('#megacolumn2').html(data);
				if (hasEditions === true) {
					addSlugCode();
				}
			},
			"html");
	var paramsmegamenu3 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 3"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu3,
			function(data, status, xhr) {
				$('#megacolumn3').html(data);
				if ( hasEditions === true) {
					addSlugCode();
				}
			},
			"html");
	var paramsmegamenu4 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 4"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu4,
			function(data, status, xhr) {
				$('#megacolumn4').html(data);
				if (hasEditions === true) {
					addSlugCode();
				}
			},
			"html");
});
	
</script>
<nav class="megamenu">
		<div class="megamenu-inner">
			<div class="mega-mobile-nav">
				<a href="#search" class="search-btn"><i class="fas fa-search"></i></a>
				
				
			</div>
			<a href="" class="mega-close ss-delete"></a>
		
			<div class="mega-logo-content">
			<img class="mega-logo" src="https://alt.idgesg.net/images/furniture/insiderpro/insider-pro-logo-from-idg.svg" />
			
			<div class="mega-4col">
				<div class="mega-col">
					
					
						<div id="megacolumn1">
						</div>
				</div>
				<div class="mega-col">
						 <div id="megacolumn2">
						</div>
				</div>
				<div class="mega-col">
					
						
						
							<div class="mega-grp insider-controls">
								<div class="signin-register">
									<div class="ip-logged-out">
										<div class="become-insider mega-hed">Join Insider Pro</div>
										<a href="#" class="ip-login">Log In</a> 
										<a href="/subscribe">Subscribe</a>
									</div>
									<div class="ip-logged-in">
										<a href="#" class="ip-logout">Logout</a> 
										<a href="/subscribe/my-account" class="ip-my-account">My Account</a>
									</div>
								</div>
							</div>
						
					
					 <div id="megacolumn3">
					 </div>
				</div>
				<div class="mega-col">
					<div class="mega-grp idg-network">
						<div class="mega-hed ss-directright right">More from the IDG Network</div>
						
							<div id="megacolumn4">
						    </div>
					</div>
				</div>
			</div>
			</div>
			
			<div class="mega-footer">
				    	<ul class="mega-about">
				    		
		            		
							
							
							
								<li><a href="/about/about.html"  >About Us</a> <span class="bar">|</span>
							
								<li><a href="/about/contactus.html"  >Contact</a> <span class="bar">|</span>
							
								<li><a href="/about/privacy.html"  >Privacy Policy</a> <span class="bar">|</span>
							
								<li><a href="/about/cookie-policy.html"  >Cookie Policy</a> <span class="bar">|</span>
							
								<li><a href="/about/member-preferences.html"  >Member Preferences</a> <span class="bar">|</span>
							
								<li><a href="https://www.idg.com/advertise-with-us/" target="_blank" rel="nofollow" >Advertising</a> <span class="bar">|</span>
							
								<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow" >IDG Careers</a> <span class="bar">|</span>
							
								<li><a href="/about/adchoices.html"  >Ad Choices</a> <span class="bar">|</span>
							
								<li><a href="/about/tos.html"  >Terms of Service</a> <span class="bar">|</span>
							
								<li><a href="/about/ccpa.html"  >California: Do Not Sell My Personal Info</a> <span class="bar">|</span>
							
						
		            	</ul>
		            	<ul class="mega-social">
	            			
							
								<li><a class="social-media-tw" href="https://twitter.com/InsiderPro_IDG" rel="nofollow" target="_blank"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
							
							
								<li class="lkndn"><a class="social-media-li" href="https://www.linkedin.com/company/insider-pro-idg" rel="nofollow" target="_blank"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
							
							
							
	            		</ul>
		            

		</div>
	</div>
	<div class="mega-submenu">
			<a href="" class="mega-mobile-nav ss-left"></a>
			<a href="" class="mega-close ss-delete"></a>
			<div class="submenu-contents"></div>
	</div>
</nav>







<script>
var relatedTop;
</script>

		
	<link rel="stylesheet" href="/www/css/content-ribbon.css?v=20200121111141" />

	











<!-- Related Content -->




	<div class="related-content-wrapper">
		<div class="sector apart">
			
	    	<ul class="ribbon-row">
	    		    	
		    	

		    		
						
						
						
					














<li class="item-0 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3482096/good-tech-talent-is-still-hard-to-find-how-to-bridge-the-gap.html">Good tech talent is still hard to find (how to bridge the gap)</a></div>
	</div>
</li>


	<li class="ribbon-col ribbon-hed">
		<div class="item">
			<div class="title">
				RELATED STORIES
			</div>
		</div>
	</li>



					
		    	

		    		
						
						
						
					














<li class="item-1 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3452839/why-kubernetes-is-vital-for-your-business.html">Why Kubernetes is vital for your business</a></div>
	</div>
</li>




	<li class="ribbon-col nativo-ribbon-item">
		<div class="title">
			<span class="item-eyebrow">SPONSORED BY <i>Advertiser Name Here</i></span>
			<a href="">Sponsored item title goes here as designed</a>
		</div>	
	</li>

					
		    	

		    		
						
						
						
					














<li class="item-2 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3449437/7-mobile-security-threats-that-may-catch-you-by-surprise.html">7 mobile security threats that may catch you by surprise</a></div>
	</div>
</li>




					
		    	
		    	
		    	
					
						
							
							
							
							
							
							
							
							
							
						






























































					
					
				
		    </ul>
		</div>
	</div>

	<script>
	// Remove related content ribbon if device is less than tablet size (768px)
	if ($thm.deviceWidthLessThan($thm.deviceBreakpoints.tablet)) {
		$('.related-content-wrapper').remove();
	}

	</script>
	



<script>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</script>

	
	



		
		













<div id="page-wrapper" class="page-wrapper">
	
	













<div id="skinAdTarget"></div>


			
		











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





	
	
 	


	
	<section role="main">
	
		
		
			<div class="piano-marketing-top"></div>
		
		

		<article itemscope itemtype="http://schema.org/Article"  >

		















<!-- Events Header -->

 
 
	
		
		
		
		
		
					    			
		
	
	
	
	
	

 
 
 
 
  
  
 
 












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


<!-- //end Events Header -->


	
	
	
	
	
	
		
	



	
		
	
	
		



































<script src="/www/js/date-time-moments.js"></script>


	
	
		<script>
		// non-edition sites
		$(document).ready(function() {
			var fullDate = "2020-01-22T05:55-0800";
			var dateFormat = "MMMM D, YYYY";
			timeDate = moment(fullDate).tz('America/Los_Angeles').format(dateFormat); // 12 hour format
			document.querySelector(".format-date").textContent = timeDate;
		});
		</script>
	



















	
			















<header class='cat'>

	
	
	
	
	
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a class="edition-link-url" href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
					<li><a class="edition-link-url primary-cat-url" href="/category/application-development/" itemprop="url"><span class="primary-cat-name" itemprop="title">Software Development</span></a></li>
				
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
	
	
	
		
		
			<div class="category"></div>
		
	
	

	<h1 itemprop="headline">Can developers dictate how their software is used?</h1>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">The politics of the Silicon Valley are colliding with customers and impacting innocent bystanders who put their trust in open source software.</h3>
		</section>
	
	
	
	
	
	
	
	
			<div class="cat-social">
				
					
				















 



	

				

	
	
		
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">

	
		<li class="sosh">
			<a data-socialsite="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idginsiderpro.com%2Farticle%2F3511598%2Fcan-developers-dictate-how-their-software-is-used.html" target="_blank">
				<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
			</a>
		</li>	
	<li class="sosh">
		<a data-socialsite="Twitter" class="twit-hand" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.idginsiderpro.com%2Farticle%2F3511598%2Fcan-developers-dictate-how-their-software-is-used.html&via=InsiderPro_IDG&text=Can+developers+dictate+how+their+software+is+used%3F" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>
	</li>
	<li class="sosh">
		<a data-socialsite="Linkedin" href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.idginsiderpro.com%2Farticle%2F3511598%2Fcan-developers-dictate-how-their-software-is-used.html&title=Can+developers+dictate+how+their+software+is+used%3F" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg" />
		</a>
	</li>	
	<li class="sosh hide">
			<a data-socialsite="Reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fwww.idginsiderpro.com%2Farticle%2F3511598%2Fcan-developers-dictate-how-their-software-is-used.html&title=Can+developers+dictate+how+their+software+is+used%3F" target="_blank">
				<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
			</a>
	</li>	
	<li class="sosh hide">
		<a href="mailto:?Subject=Can developers dictate how their software is used?&Body=Check%20out%20this%20article%20from%20InsiderPro%3A%20https%3A%2F%2Fwww.idginsiderpro.com%2Farticle%2F3511598%2Fcan-developers-dictate-how-their-software-is-used.html" target="_blank" rel="nofollow" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />	
		</a>
	</li>
	<li class="sosh hide print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>
	<li class="more">
		<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
	</li>




</ul>
</div>

<script type="text/javascript">
$(document).ready(function() {
	if (twitterHandle != "") {
		$("a[href*=via]").attr("href", function(_, href) {
			  return href.replace(/via=InsiderPro_IDG/, "via="+twitterHandle);
		});
	}
	
	//Add Social Share Event Tag in GTM - IDGMPM-17271
	$("a[data-socialsite]").click(function() {
		var dataLayer = window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'socialShare', 
		  	'eventCategory': 'Social Share',
		  	'eventAction': $(this).attr("data-socialsite"), 
		  	'eventLabel': window.document.title
		});
		
	});
});
</script>

<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}
</script>

			</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Andy-Patrizio/" rel="author" title="Andy Patrizio"><img  class="bylineImage  imgId100812328 " src="https://images.idgesg.net/images/article/2019/09/patrizio-100812328-byline.jpg" width="34" width="34" alt="Andy Patrizio" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Andy-Patrizio/"><span itemprop="name">Andy Patrizio</span></a></span>
						</p>
						<p class="dateline">
						
							
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"></span><meta itemprop="logo" content="https://alt.idgesg.net/images/furniture/insiderpro/favicon_package/IP-favicon-300x300.png"/></span> <span class="divider">|</span>
							
	
							<span class="pub-date"  itemprop="datePublished" 
							    content="2020-01-22T05:55-0800"><span class="format-date"></span>
								
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
		
	
	
	
	
	
</header>




	<div class="constrain-970">
		
		
		
		
			
				<div class="lede-container">
					
					
					
						
						
							
				                
				                	
				                	
				                
				                
								
								
								
							
							
							
							
							<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
								<meta itemprop="representativeOfPage" content="1" />
								<meta itemprop="height" content="467" />
								<meta itemprop="width" content="700" />
					    		
					    		<img data-original="https://images.techhive.com/images/article/2016/11/six-big-projects-that-went-open-source-1-100692064-large.jpg" class="lazy" loading="lazy" alt="six big projects that went open source 1" itemprop="contentUrl" itemprop="url" />
					    		
					    		<figcaption>
					    			
					    			
					    				<span class="credit" itemprop="copyrightHolder">
					    					
							    				
							    				Thinkstock
						    				
				
							    			
							    				
							    				
							    				
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
							    				
							    				
												
											
									
										</span>
					    			
									
					    		</figcaption>
							</figure>
							
				
						
						
					
				</div>
			
			
		
	



<section class="epo cat-narrow" id="drr-top-ad">

	
	
	
	
	
	
		<div class="ad top-ad">
	
		
		
			
				
					
					
						
					
				
				
				
			




















		
	
</div>
	
	
	
	
	
	
	
	
	
</section>

</div>







<div class="constrain-970">
	
</div>




<script src="/www/js/deal-modules.js"></script>

		
		



		<section class="bodee">

			
				
				
					












	
		





















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery.rr-gallery-vid #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 300px !important;
		height: 169px !important;
		transition: all 0.5s ease;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container .jw-icon,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jw-state-idle .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.thm-gallery.rr-gallery-vid .jw-state-complete .jw-svg-icon-replay  {
	height: 65px;
    width: 62px;
}
</style>


	



	
	
	
	
	
	
	
	
	
	
	
		
		
			
			
			<script>
				var dataLayer = window.dataLayer = window.dataLayer || [];
				dataLayer.push({
					'event': 'loadTopCollectionModule'
					});
			</script>
			
		
	
	
	
	
	













<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
			
	
		
	
			
			













<style>
@media only screen and (min-width: 60.625em) {
	article .apart.ad.not-lazy {
		margin-left: 0;
		float: right;
	}
}
/* this spaces the ads in the right rail */
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
</style>


<script type="text/javascript">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</script>
			
			
	
	
	
	
	
		
		
			
		
	
	
	
	
	
		
			
				
				
				
					
				
				
			
		
		
	
	
		
		
			<div id="drr-container" class='cat ' itemprop="articleBody">
		
		
		
		
	
		
			
				<div class="teaser">
					<!--  teaser content goes here -->
					<p>The political leanings of the Silicon Valley are no secret, a strange brew considering the Silicon Valley resembles the era of the robber barons like JD Rockefeller and JP Morgan. Rampant capitalism making instant billionaires has thus far co-existed with rabid supporters of Sen. Bernie Sanders, who has said billionaires should not exist.</p>
<p>But lately, the progressive attitudes of the Valley and tech industry in general are coming into conflict, with the loudest recent incident coming last September when a software engineer pulled a personal project down from GitHub after he learned it was being used by the U.S. Immigrations and Customs Enforcement (ICE).</p>
<aside class="fakesidebar">
<h4><strong>[ Don't miss: </strong> <a href="https://www.idginsiderpro.com/author/Mike-Elgan/"> Mike Elgan every week on Insider Pro </a> ]</h4>
</aside>
<p>The developer, Seth Vargo, cited the ICE's "inhumane treatment, denial of basic human rights, and detaining children in cages" as the reason for taking down his project, known as <a href="https://github.com/chef/chef-sugar" rel="noopener nofollow" target="_blank">Chef Sugar</a>, a Ruby library for simplifying the use of Chef, a platform for server configuration management. Varga developed the library while he worked at Chef, and the library was later integrated into Chef's platform.</p>
<aside class="pullquote"><q>That’s the problem with this. It flies in the face of what open source was supposed to be about. </q></aside>
<p>The company restored it to the service, with Chef CEO Barry Crist <a href="https://blog.chef.io/chefs-position-on-customer-engagement-in-the-public-and-private-sectors/" rel="noopener nofollow" target="_blank">noting</a> the removal of the software had impacted “production systems for a number of our customers.” Crist went on to say he did not think it was appropriate, practical, or within Chef’s mission to decide which U.S. agencies it should or should not do business with. </p>
<p>The resulting blowback saw Microsoft, which owns GitHub, and GitHub itself under</p>
				</div>
				<div class="empty-div"></div>
				<div class="piano-offer">
					<!-- this is where the piano offer will inject if the conditions are met -->
				</div>
				<div class="premium">
					<!--  entire article body goes here -->
			    	<p>The political leanings of the Silicon Valley are no secret, a strange brew considering the Silicon Valley resembles the era of the robber barons like JD Rockefeller and JP Morgan. Rampant capitalism making instant billionaires has thus far co-existed with rabid supporters of Sen. Bernie Sanders, who has said billionaires should not exist.</p><p>But lately, the progressive attitudes of the Valley and tech industry in general are coming into conflict, with the loudest recent incident coming last September when a software engineer pulled a personal project down from GitHub after he learned it was being used by the U.S. Immigrations and Customs Enforcement (ICE).</p><aside class="fakesidebar">
<h4><strong>[ Don't miss: </strong> <a href="https://www.idginsiderpro.com/author/Mike-Elgan/"> Mike Elgan every week on Insider Pro </a> ]</h4>
</aside><p>The developer, Seth Vargo, cited the ICE's "inhumane treatment, denial of basic human rights, and detaining children in cages" as the reason for taking down his project, known as <a href="https://github.com/chef/chef-sugar" rel="noopener nofollow" target="_blank">Chef Sugar</a>, a Ruby library for simplifying the use of Chef, a platform for server configuration management. Varga developed the library while he worked at Chef, and the library was later integrated into Chef's platform.</p><aside class="pullquote"><q>That’s the problem with this. It flies in the face of what open source was supposed to be about. </q></aside><p>The company restored it to the service, with Chef CEO Barry Crist <a href="https://blog.chef.io/chefs-position-on-customer-engagement-in-the-public-and-private-sectors/" rel="noopener nofollow" target="_blank">noting</a> the removal of the software had impacted “production systems for a number of our customers.” Crist went on to say he did not think it was appropriate, practical, or within Chef’s mission to decide which U.S. agencies it should or should not do business with. </p><p>The resulting blowback saw Microsoft, which owns GitHub, and GitHub itself under pressure not to work with the government. Microsoft employees also staged a revolt over the company’s work with the Department of Defense (DoD) over the military’s use of the HoloLens headset. Google employees have also revolted against their company bidding for the $10 billion DoD JEDI contract and forced it to <a href="https://observer.com/2018/10/google-pentagon-jedi/" rel="noopener nofollow" target="_blank">drop out of the bidding</a>.</p><h2>Whose software is it anyway?</h2><p>The issue comes down to software ownership vs. customer dependence. Stephen O’Grady, principal analyst with IT research firm Redmonk, notes there are two issues at play here: Do you have an obligation to your customers to support products in a predictable way? And can you deny the right to a particular product or products for a particular customer?</p><p>“The answer to the first question, in my opinion, is yes. Particularly for enterprise buyers, the assurance that investments made will be supported over time rather than unpredictably abandoned is huge. It’s part of the basis, in fact, for the old adage that you don’t get fired for buying IBM: the company has a reputation for standing behind the products it sells for long periods of time, making investments in them safe,” O’Grady said.</p><p>As for the second question, that’s more complicated, but he still says yes. “In general, companies try not to discriminate against certain types of buyers, both because it goes against the business interests of maximizing revenue, but also because it’s a difficult practice to manage both in terms of legal liability and the public relations appearance and precedent,” he added.</p><p>Shayne Sherman, CEO of TechLoris, a PC maintenance and repair site, says ultimately, it is the developer's prerogative to decide whether or not they want to keep their app on the market.</p><p>“It doesn't matter whether or not others have become invested or dependent on the program. Companies go under all the time and to expect that there should be consequences for no longer providing their services would be unrealistic. The same would be true if a developer deliberately chose to no longer offer their program,” he said.</p><p><strong>[ Related article: <a href="https://www.infoworld.com/article/2648369/the-many-overlaps-of-politics-and-technology.html" rel="noopener" target="_blank">The many overlaps of politics and technology ]</a></strong></p><p>He added that there is no moral obligation on the developer to continue to offer their program, however, there might be legal obligations. “If the developer sold the distribution rights, the developer might no longer have a say in whether or not they can close an app. Open source would suggest the app is not under such legal obligations. The main issue would likely be if others had access to the original source code for the app, meaning someone else could potential redistribute this app without legal repercussions,” he said.</p><p>Akshay “Ax” Sharma, a security researcher at Sonatype and <a href="https://www.cio.com/author/Akshay-Sharma/" rel="noopener" target="_blank">IDG Influencer</a>, said things depend on the license used. “Once you release under a <a href="https://en.wikipedia.org/wiki/Copyleft" rel="noopener nofollow" target="_blank">copyleft license</a>, you have already released partial rights to work. How do you take it back? [Essentially,] you forfeit your own right to say I want it back once I released it under an open-source license,” he said.</p><p>Copyleft licenses, used in many open-source licenses, are meant to be freer and more permissive than standard copyrights. Those who download the software are within their rights to modify and release their own version so long as they make the code available and include the copyleft license with the code.</p><p>Vargo’s move “essentially makes [copyleft] no different from copyright. One of the criticisms of copyright was content creators get to control the culture,” he said. “When I read these articles, it was like, ok you partially waived your right to your work, and then you did not like how that work was used, so you want to reclaim that right even though you’ve already waived it.”</p><p><strong>[ Related article: <a href="https://www.cio.com/article/3186516/is-open-source-the-transformative-solution-for-activism.html" rel="noopener" target="_blank">Is open source the transformative solution for activism? ]</a></strong></p><h2>Potential blowback for open source?</h2><p>The question then becomes what does this do for open-source software’s image. This type of activity is unthinkable coming from Microsoft, Oracle or SAP, but will enterprises be reluctant to use a product from a small development house if the developer gets woke?</p><p>Rick Stafford, professor public policy at Carnegie Mellon University's Heinz College, said he understands the ethical dilemma for a developer to want their product to be used and then it gets used in a way they don’t agree with. But what if a new administration comes along and uses the product in a way you agree with?</p><p>“If you set the precedent that it can be withdrawn and disrupted, the next administration might say I’m not going to use that again. I’m gonna go elsewhere because I’m not going to go back to the people who withdrew the code. There is too much risk there,” he said.</p><p>“You could in essence blackmail people,” he added. “That’s the problem with this. It flies in the face of what open source was supposed to be about. It’s like making a promise. Open source is saying OK you can use this, then say you can’t? Open source is a promise in a sense.”</p><p>Stafford said he believes the industry has to work it out on its own because otherwise it falls to the government for a legislative solution, and we all know how that usually goes. Poorly. “If there is to be a law, the industry should play the first role and say let’s work this out among ourselves. We’re not going to get elected officials to figure this all out,” he said.</p><p>O’Grady said it can raise questions, certainly, but doesn’t believe it’s a systemic concern for buyers at present. “It’s at least in theory of no greater concern than for proprietary software, because once the code has been published under an open-source license, it can be legally used according to the terms of that license in perpetuity,” he said.</p><p>Sharma has discussed the Chef incident with peers and said the reaction was “very polarized” and it came down to personal ethics and morals. “Some colleagues said this is open-source software, why is he pulling back, but others said they don’t like the purpose it was used for. Most sided with developer, but I also saw the backlash about how this impacts open source in general,” he said.</p><p>So for now, it seems there is no negative reaction to Vargo’s actions, but if it happens a few more times the mood could turn negative, and trust is not easily regained.</p>
				</div>
			
			
		
		
	
		
		
			
		
		
		
		
			
			
			
			










<div class="end-note">
	
		
	











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


</div>
		
		
	</div>
	
	
	
		
		
		
	
	


	
	
	<script>
$("body").on('click', 'a[data-product-id]', function() {
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
	
	window.permutive.track('AffiliateLinkClick', {
	    category: $(this).attr("data-bkc"),
	    name: prodName,
	    manufacturer: $(this).attr("data-bkmfr"),
	    vendor: $(this).attr("data-bkvndr")
	});
	
});
</script>
	
	
		<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com|csoonline.com|computerworld.com|itnews.com|itworld.com|infoworld.com|networkworld.com|javaworld.com|techconnect.com|techhive.com|macworld.com|pcworld.com|greenbot.com|gamestar.com", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	
	
	<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	
	
	
	
	
	
	    <div class="apart-alt tags">
	    <span class="related">Related: </span>
	    <ul>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/application-development"><span class="primary-cat-name2">Software Development</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/open-source-tools"><span class="primary-cat-name2">Open Source</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/devops"><span class="primary-cat-name2">Devops</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/technology-business"><span class="primary-cat-name2">Technology Industry</span></a></li>
			 
			
				
				
					 
						 
				    				
					
				
					
			
	    </ul>
	   
		</div>
	
	
	
	
	
	
	
	
	
			
	   		












	
	
		<div class="byline vcard author end-byline">	
			<div class="author-info">
					<p class="bio"><p>Andy Patrizio is a freelance journalist based in southern California who has covered the computer industry for 20 years and has built every x86 PC he’s ever owned, laptops not included.</p></p>
			</div><!-- end .author-info -->
			<div class="brand-social">
				<div class="follow-text">Follow</div>
				<ul class="social-links">
					<li>
						<a href="/author/Andy-Patrizio/">
							<i class="ss-icon ss-user"></i>
						</a>
					</li>
					
					
						<li>
							<a href="https://twitter.com/apatrizio" class="twitter-follow" target="_blank">
								<i class="ss-icon ss-social ss-twitter"></i>
							</a>
						</li>
					
					
					
						<li>
							<a href="https://www.linkedin.com/in/apatrizio" class="linkedin-follow" target="_blank">
								<i class="ss-icon ss-social ss-linkedin"></i>
							</a>
						</li>
					
					
						<li>
							<a href="/author/Andy-Patrizio/index.rss" class="rss">
								<i class="ss-icon ss-social ss-rss"></i>
							</a>
						</li>
					
				</ul>
			</div>			
		</div>
	



	   		
	   		
			
	
	
	
	
		 
	
	
	
	
	
		
		
	

















	 
	



	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder-jwp.js?v=20200121111141"></script>


	
	
	
	




					










				
			
		
		</section><!-- /.bodee -->

		















	
		
			
				
				
					

				
			
			
		

		
			
			
		
			
							
	
	


	
	
	


		</article>

	</section><!-- /role=main -->

	
	
		<div class="piano-marketing-bottom"></div>
	
	

</div><!-- /#page-wrapper -->
		
		












	<link rel="stylesheet" href="/www.idge/css/foot.css?v=20200121111141" />
	<link rel="stylesheet" href="/www.idge.insp/css/foot.css?v=20200121111141" />

<footer>
    <section class="brand" itemscope itemtype="http://schema.org/Organization">
   	
   		<link itemprop="url" href="http://www.idginsiderpro.com"> 
        <a href="/"><span class="logo">InsiderPro</span></a>
		<span class="tagline"> </span>
        
        
	        <span class="follow">
				<label>Follow us</label>
	            	<ul>
	            		














	
		<li><a class="social-media-tw-foot" href="https://twitter.com/InsiderPro_IDG" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
	
	
	
		<li class="lnkdn"><a class="social-media-li-foot" href="https://www.linkedin.com/company/insider-pro-idg" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
	
	
	
	
	
	
	
	
	
		<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
	
	
	
	


	            	</ul>
	        </span>
        
        
    </section>
    
    
    <section class="about">
		<div class="wrapper"> 
        	<nav class="tertiary" id="ft3">
            	<ul>
            		
















<li><a class="edition-link-url" href="/about/about.html"  >About Us</a>

<li><a class="edition-link-url" href="/about/contactus.html"  >Contact</a>

<li><a class="edition-link-url" href="/about/privacy.html"  >Privacy Policy</a>

<li><a class="edition-link-url" href="/about/cookie-policy.html"  >Cookie Policy</a>

<li><a class="edition-link-url" href="/about/member-preferences.html"  >Member Preferences</a>

<li><a class="edition-link-url" href="https://www.idg.com/advertise-with-us/" target="_blank" rel="nofollow" >Advertising</a>

<li><a class="edition-link-url" href="https://www.idg.com/work-here/" target="_blank" rel="nofollow" >IDG Careers</a>

<li><a class="edition-link-url" href="/about/adchoices.html"  >Ad Choices</a>

<li><a class="edition-link-url" href="/about/tos.html"  >Terms of Service</a>

<li><a class="edition-link-url" href="/about/ccpa.html"  >California: Do Not Sell My Personal Info</a>




            	</ul>
        	</nav>
		</div>
	</section>
	
    <section class="copyright">
        <div class="wrapper">
			
        	
        
        	
        	<p><a href="/about/copyright.html">Copyright</a> &copy; 2020 IDG Communications, Inc.</p>
			<div class="network">
				<div id="network-selector">
                <div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
                <ul>
                	
                		
                		
                	














	
		<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
	
		<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
	
		<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
	
		<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
	
		<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
	
		<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
	
		<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">InfoWorld</a></li>
	
		<li><a href="https://www.idginsiderpro.com" target="_blank" rel="nofollow">Insider Pro</a></li>
	
		<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
	
		<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
	

                </ul>
				</div><!-- /#network-selector -->
			</div><!-- /.network -->
		</div><!-- /.wrapper -->
    </section>
</footer>


<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>







<script src="/www/js/analytics/tracking.js"></script>
<script src="/www/js/autocomplete.js"></script>


	<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
	<script src="/www.idge/js/article.js?v=20200121111141"></script>
	
	<script src="/www.idge/js/jquery/responsive-tables.js"></script>
	<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
	<script>
	$(document).ready(function() {
		$("table.tablesorter").tablesorter({
			widgets: ['zebra']
		});
		
		$("table.tablesorter tbody tr").hover(function() {
			$(this).toggleClass("selected");
		});
		
		$("table.tablesorter thead tr th").each(function(){			
			if ($(this).find('.ss-icon').length < 1) {
				$(this).append('<i class="ss-icon"></i>');
			}
		});
		
	});
	</script>
	




<script src="/www.idge/js/global.js?v=20200121111141"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>




















	



<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>


<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
$("div.lazyload_ad").lazyLoadAd({
        threshold    : 500,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
        onLoad       : false,       // Callback function on call ad loading
        onComplete   : false,       // Callback function when load is loaded
        timeout      : 1500,        // Timeout ad load
        debug        : false,       // For debug use : draw colors border depends on load status
        xray         : false        // For debug use : display a complete page view with ad placements
}) ;
</script>





	
	
	

	<script>
	    (function(src) {
	        var a = document.createElement("script");
	        a.type = "text/javascript";
	        a.async = true;
	        a.src = src;
	        var b = document.getElementsByTagName("script")[0];
	        b.parentNode.insertBefore(a, b)
	    })("//experience.tinypass.com/xbuilder/experience/load?aid=saWAPlOfqK");
	</script>



<script type='text/javascript'>

	var ocHead = $("#oc-head").outerHeight();
	var relatedContentHeight = $(".related-content-wrapper").outerHeight();
	relatedTop = ocHead+50;
		$(document).ready(function() {
			function debounce(func, wait, immediate){
			    var timeout;
			    return function(){
			        var context = this, args = arguments;
			        var later = function(){
			            timeout = null;
			            if (!immediate) func.apply(context, args);
			        };
			        var callNow = immediate && !timeout;
			        clearTimeout(timeout);
			        timeout = setTimeout(later, wait);
			        if (callNow) func.apply(context, args);
			    };
			}
			
			 var lastScrollTop = 0;
			 
			 if (window.addEventListener) {
		        window.addEventListener('scroll', debounce(function(e){
		        
		        var containerOffset = $("#drr-container p:last").offset().top;
			    var containerHeight = $("#drr-container p:last").outerHeight();
			    var windowHeight = $(window).height();
			    var windowScrolltop = $(this).scrollTop();

			    if (windowScrolltop > lastScrollTop) {
			    	// user is scrolling DOWN: hide ribbon
			    	$(".related-content-wrapper").css('top','-'+relatedTop+'px');
			    	
		    	 	if ((windowScrolltop > (containerOffset+containerHeight-windowHeight))&& !($('#oc-head').hasClass('no-stick-important'))) {
			    		// user is scrolling down and sees last paragraph: show ribbon
			    		$(".related-content-wrapper").css('top',ocHead+'px');
		    		}
			    	
			    } else {		        	
			    	$(".related-content-wrapper").css('top','-'+relatedTop+'px');
			    }
			   
			   	lastScrollTop = windowScrolltop;
					
		               
		        }, 5));   // run maximum of one time every 5ms
		    }
		    
		});
	
</script>












	
		
	
	
		
	
	

<!-- Begin comScore Tag -->
<script>
var _comscore = _comscore || [];
_comscore.push(
{ c1: "2", c2: "6035308", c3: "", c5: "Software Development", c6: "Article: Feature", c15: "3511598" });
(function()
{
	var s = document.createElement("script"), el = document.getElementsByTagName("script")[0];
	s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
	el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->














<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"insp","e":"view","t":"article","id":"3511598"});
});
</script>

		<div id="loginModal"></div>
		<div id="logoffModal"></div>

		
		
		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>			

		













	</body>
</html>